Your submission was sent successfully! Close

USN-5479-1: PHP vulnerabilities

15 June 2022

Several security issues were fixed in PHP.

Releases

Packages

  • php7.2 - HTML-embedded scripting language interpreter
  • php7.4 - HTML-embedded scripting language interpreter
  • php8.0 - HTML-embedded scripting language interpreter
  • php8.1 - HTML-embedded scripting language interpreter

Details

Charles Fol discovered that PHP incorrectly handled initializing certain
arrays when handling the pg_query_params function. A remote attacker could
use this issue to cause PHP to crash, resulting in a denial of service, or
possibly execute arbitrary code. (CVE-2022-31625)

Charles Fol discovered that PHP incorrectly handled passwords in mysqlnd. A
remote attacker could use this issue to cause PHP to crash, resulting in a
denial of service, or possibly execute arbitrary code. (CVE-2022-31626)

Related notices

  • USN-5479-2: php7.0-soap, php7.0-odbc, php7.0-ldap, php7.0-mcrypt, php7.0-enchant, php7.0-mbstring, php7.0-gd, php7.0-gmp, php7.0-json, php7.0-sybase, php7.0-bz2, php7.0, php7.0-fpm, php7.0-pspell, php7.0-mysql, php7.0-cli, php7.0-intl, php7.0-opcache, php7.0-tidy, php7.0-sqlite3, php7.0-imap, php7.0-zip, php7.0-interbase, php7.0-pgsql, php7.0-bcmath, php7.0-xmlrpc, php7.0-snmp, php7.0-xml, php7.0-recode, php7.0-common, libphp7.0-embed, php7.0-readline, php7.0-dev, php7.0-phpdbg, php7.0-dba, php7.0-cgi, php7.0-xsl, libapache2-mod-php7.0, php7.0-curl