Your submission was sent successfully! Close

USN-5479-2: PHP vulnerabilities

4 July 2022

Several security issues were fixed in PHP.

Releases

Packages

  • php7.0 - HTML-embedded scripting language interpreter

Details

USN-5479-1 fixed vulnerabilities in PHP. This update provides the
corresponding updates for Ubuntu 16.04 ESM.

Original advisory details:

Charles Fol discovered that PHP incorrectly handled initializing certain
arrays when handling the pg_query_params function. A remote attacker could
use this issue to cause PHP to crash, resulting in a denial of service, or
possibly execute arbitrary code. (CVE-2022-31625)

Charles Fol discovered that PHP incorrectly handled passwords in mysqlnd. A
remote attacker could use this issue to cause PHP to crash, resulting in a
denial of service, or possibly execute arbitrary code. (CVE-2022-31626)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04

In general, a standard system update will make all the necessary changes.

Related notices

  • USN-5479-1: php8.0-mysql, php7.2-recode, php7.2-bz2, php7.4-sybase, php7.4-dba, php8.1-snmp, php8.0-common, php7.4-pgsql, php7.4-cli, php8.0, php8.0-cgi, libapache2-mod-php7.2, php7.2-readline, php8.1-bz2, php8.0-imap, php8.1-pspell, php8.0-bcmath, libapache2-mod-php8.0, php7.4-json, php7.2-pgsql, php7.2-json, php7.2-pspell, php7.4-enchant, php7.4-soap, php8.1-mbstring, libapache2-mod-php8.1, php8.0-tidy, php7.4-xsl, php7.4-pspell, php7.2-soap, php8.1-tidy, php7.4-zip, php8.0-xml, php8.1-imap, php8.1-phpdbg, php7.4-phpdbg, php7.2-mbstring, php7.4-curl, php8.1-readline, php7.2-dev, php8.0-odbc, php7.4-gmp, php8.0-cli, php8.1-dev, php8.1-fpm, php7.2-opcache, php7.2-xsl, php8.1-interbase, php7.4-mysql, php8.0-fpm, php7.2-cgi, php8.0-gmp, php7.2-tidy, php8.0-pspell, php8.0-ldap, php7.4-dev, php8.0-zip, php8.0-soap, php8.0-bz2, php7.2-dba, php7.2-mysql, php7.4-gd, php7.4-opcache, php7.2-curl, php7.4-cgi, php7.4-mbstring, php8.0-opcache, php8.1-soap, libphp7.4-embed, php7.2-xml, php8.0-sybase, php7.2-xmlrpc, php7.4-readline, php7.2-sybase, php8.0-enchant, php7.4-intl, php7.2-enchant, php7.4-tidy, php8.1-cli, php8.1, php8.1-dba, php8.1-cgi, php8.1-common, php7.4-ldap, php8.0-dba, php7.4-xml, php8.0-readline, php8.1-sqlite3, php8.0-dev, php7.2, php7.2-odbc, php7.4-bcmath, php8.0-snmp, php8.1-odbc, php8.1-sybase, php8.1-xml, php7.2-cli, php7.2-intl, php8.0-sqlite3, php8.1-curl, php7.4-snmp, php8.0-interbase, php7.2-zip, php8.0-mbstring, php7.4-sqlite3, php7.2-snmp, php8.1-enchant, php8.0-gd, php7.4-bz2, php7.4-common, php7.4-xmlrpc, php8.1-bcmath, php8.1-pgsql, php8.0-phpdbg, php8.1-ldap, php7.4-imap, php8.0-xsl, php7.2-ldap, php7.2-phpdbg, php7.4-odbc, php7.2-sqlite3, libphp8.1-embed, libphp8.0-embed, php8.0-curl, php8.1-mysql, php7.2-bcmath, php7.2-imap, php8.1-zip, php7.2-gd, php8.0-intl, php7.4-interbase, php8.1-opcache, php7.2-gmp, php8.1-gd, php8.1-intl, php7.2-interbase, libapache2-mod-php7.4, php8.1-gmp, php8.1-xsl, php7.2-fpm, libphp7.2-embed, php7.4, php8.0-pgsql, php7.2-common, php7.4-fpm
  • USN-5479-3: php7.2-xml, php7.2-xmlrpc, php7.2-sybase, php7.2-recode, php7.2-bz2, php7.2-ldap, php7.2-mbstring, php7.2-enchant, php7.2-dev, libapache2-mod-php7.2, php7.2-phpdbg, php7.2-sqlite3, php7.2-readline, php7.2-opcache, php7.2-xsl, php7.2-bcmath, php7.2-imap, php7.2-cgi, php7.2-gd, php7.2-tidy, php7.2-pgsql, php7.2, php7.2-odbc, php7.2-json, php7.2-pspell, php7.2-gmp, php7.2-interbase, php7.2-dba, php7.2-mysql, php7.2-cli, php7.2-intl, php7.2-soap, php7.2-fpm, libphp7.2-embed, php7.2-curl, php7.2-zip, php7.2-snmp, php7.2-common