Your submission was sent successfully! Close

USN-5145-1: PostgreSQL vulnerabilities

11 November 2021

PostgreSQL could allow unintended access to network services.

Releases

Packages

Details

Jacob Champion discovered that PostgreSQL incorrectly handled SSL
certificate verification and encryption. A remote attacker could possibly
use this issue to inject arbitrary SQL queries when a connection is first
established.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 21.10
Ubuntu 21.04
Ubuntu 20.04
Ubuntu 18.04

This update uses a new upstream release, which includes additional bug
fixes. After a standard system update you need to restart PostgreSQL to
make all the necessary changes.

Related notices

  • USN-5645-1: libecpg-compat3, postgresql-contrib-9.5, postgresql-plpython-9.5, postgresql-client-9.5, libpgtypes3, postgresql-server-dev-9.5, libecpg-dev, libpq-dev, postgresql-doc-9.5, postgresql-plpython3-9.5, postgresql-pltcl-9.5, libecpg6, postgresql-9.5, postgresql-plperl-9.5, libpq5