Your submission was sent successfully! Close

CVE-2021-23214

Published: 11 November 2021

When the server is configured to use trust authentication with a clientcert requirement or to use cert authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of SSL certificate verification and encryption.

Priority

Medium

CVSS 3 base score: 8.1

Status

Package Release Status
postgresql
Launchpad, Ubuntu, Debian
upstream Needs triage

postgresql-10
Launchpad, Ubuntu, Debian
bionic
Released (10.19-0ubuntu0.18.04.1)
focal Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Does not exist

upstream
Released (10.19)
xenial Does not exist

postgresql-12
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (12.9-0ubuntu0.20.04.1)
hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Does not exist

upstream
Released (12.9)
xenial Does not exist

postgresql-13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute
Released (13.5-0ubuntu0.21.04.1)
impish
Released (13.5-0ubuntu0.21.10.1)
jammy Does not exist

trusty Does not exist

upstream
Released (13.5)
xenial Does not exist

postgresql-9.1
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

postgresql-9.3
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Deferred
(2019-08-23)
upstream Needs triage

xenial Does not exist

postgresql-9.5
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

trusty Does not exist

upstream Needs triage

xenial Needs triage

Notes

AuthorNote
leosilva
PostgreSQL 9.3 is end of life upstream, and no updates are
are available. Marking as deferred in -esm-main releases.
mdeslaur
Plan is for postgresql-13 to be removed from jammy, marking as
deferred for now.

References