USN-4977-1: Linux kernel vulnerabilities

03 June 2021

Several security issues were fixed in the Linux kernel.

Releases

Packages

  • linux - Linux kernel
  • linux-aws - Linux kernel for Amazon Web Services (AWS) systems
  • linux-azure - Linux kernel for Microsoft Azure Cloud systems
  • linux-gcp - Linux kernel for Google Cloud Platform (GCP) systems
  • linux-kvm - Linux kernel for cloud environments
  • linux-oracle - Linux kernel for Oracle Cloud systems
  • linux-raspi - Linux kernel for Raspberry Pi (V8) systems

Details

Kiyin (尹亮) discovered that the NFC LLCP protocol implementation in the
Linux kernel contained a reference counting error. A local attacker could
use this to cause a denial of service (system crash). (CVE-2020-25670)

Kiyin (尹亮) discovered that the NFC LLCP protocol implementation in the
Linux kernel did not properly deallocate memory in certain error
situations. A local attacker could use this to cause a denial of service
(memory exhaustion). (CVE-2020-25671, CVE-2020-25672)

Kiyin (尹亮) discovered that the NFC LLCP protocol implementation in the
Linux kernel did not properly handle error conditions in some situations,
leading to an infinite loop. A local attacker could use this to cause a
denial of service. (CVE-2020-25673)

Piotr Krysiuk and Benedict Schlueter discovered that the eBPF
implementation in the Linux kernel performed out of bounds speculation on
pointer arithmetic. A local attacker could use this to expose sensitive
information. (CVE-2021-29155)

Reiji Watanabe discovered that the KVM VMX implementation in the Linux
kernel did not properly prevent user space from tampering with an array
index value, leading to a potential out-of-bounds write. A local attacker
could use this to cause a denial of service (system crash) or possibly
execute arbitrary code. (CVE-2021-3501)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 21.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

Related notices

  • USN-4948-1: linux-image-5.10.0-1026-oem, linux-image-oem-20.04b, linux-oem-5.10, linux-image-oem-20.04-edge
  • USN-4999-1: linux-image-5.8.0-59-generic-lpae, linux-aws-5.8, linux-hwe-5.8, linux-image-generic, linux-image-generic-64k-hwe-20.04, linux-image-generic-lpae-hwe-20.04-edge, linux-image-kvm, linux-image-gcp, linux-image-virtual-hwe-20.04, linux-azure-5.8, linux-image-5.8.0-1029-raspi, linux-image-5.8.0-1038-aws, linux-image-gke, linux-image-lowlatency-hwe-20.04-edge, linux-image-virtual-hwe-20.04-edge, linux-oracle, linux-image-oem-20.04, linux-image-generic-hwe-20.04, linux-image-gcp-edge, linux-gcp-5.8, linux-azure, linux-image-generic-64k, linux-kvm, linux-image-5.8.0-1030-kvm, linux-image-generic-lpae-hwe-20.04, linux-image-raspi, linux, linux-image-generic-lpae, linux-image-5.8.0-1033-oracle, linux-image-oracle-edge, linux-gcp, linux-aws, linux-oracle-5.8, linux-image-azure-edge, linux-image-5.8.0-1035-gcp, linux-image-lowlatency-hwe-20.04, linux-image-generic-hwe-20.04-edge, linux-image-oracle, linux-image-aws, linux-image-lowlatency, linux-raspi, linux-image-raspi-nolpae, linux-image-5.8.0-1029-raspi-nolpae, linux-image-5.8.0-1036-azure, linux-image-5.8.0-59-lowlatency, linux-image-generic-64k-hwe-20.04-edge, linux-image-virtual, linux-image-5.8.0-59-generic-64k, linux-image-azure, linux-image-5.8.0-59-generic
  • USN-4982-1: linux-gke-5.4, linux-hwe-5.4, linux-image-generic, linux-image-raspi-hwe-18.04, linux-image-5.4.0-1036-raspi, linux-image-virtual-hwe-18.04, linux-gkeop, linux-image-virtual-hwe-18.04-edge, linux-image-kvm, linux-image-oem, linux-image-generic-lpae-hwe-18.04-edge, linux-image-gcp, linux-azure-5.4, linux-image-gke-5.4, linux-image-generic-lpae-hwe-18.04, linux-oracle-5.4, linux-image-5.4.0-1044-gke, linux-gcp-5.4, linux-image-gke, linux-image-5.4.0-1046-oracle, linux-image-5.4.0-1044-gcp, linux-image-raspi2, linux-oracle, linux-image-5.4.0-74-generic-lpae, linux-image-5.4.0-1016-gkeop, linux-image-generic-hwe-18.04, linux-image-gcp-edge, linux-aws-5.4, linux-azure, linux-image-5.4.0-74-generic, linux-image-snapdragon-hwe-18.04-edge, linux-image-lowlatency-hwe-18.04-edge, linux-image-5.4.0-1040-kvm, linux-kvm, linux-image-raspi, linux, linux-image-generic-lpae, linux-image-aws-edge, linux-gke, linux-image-generic-hwe-18.04-edge, linux-image-oracle-edge, linux-gcp, linux-aws, linux-image-azure-edge, linux-image-gkeop, linux-image-gkeop-5.4, linux-image-5.4.0-1049-aws, linux-image-oracle, linux-gkeop-5.4, linux-image-aws, linux-image-lowlatency, linux-image-oem-osp1, linux-image-lowlatency-hwe-18.04, linux-raspi, linux-image-raspi2-hwe-18.04-edge, linux-image-raspi2-hwe-18.04, linux-image-virtual, linux-image-azure, linux-image-snapdragon-hwe-18.04, linux-image-5.4.0-1048-azure, linux-image-raspi-hwe-18.04-edge, linux-image-5.4.0-74-lowlatency, linux-raspi-5.4
  • USN-4983-1: linux-image-oem-20.04, linux-image-oem-20.04b, linux-image-5.10.0-1029-oem, linux-image-oem-20.04-edge, linux-oem-5.10
  • USN-4979-1: linux-image-virtual-hwe-16.04-edge, linux-image-generic, linux-image-generic-lpae-hwe-16.04, linux-image-4.15.0-144-lowlatency, linux-aws-hwe, linux-image-kvm, linux-image-oem, linux-image-gcp, linux-image-snapdragon, linux-hwe, linux-snapdragon, linux-image-gke, linux-image-raspi2, linux-image-4.15.0-144-generic-lpae, linux-oracle, linux-image-4.15.0-1092-kvm, linux-image-gcp-lts-18.04, linux-azure, linux-image-4.15.0-1115-azure, linux-gcp-4.15, linux-kvm, linux-image-4.15.0-144-generic, linux, linux-image-generic-lpae, linux-image-lowlatency-hwe-16.04, linux-image-4.15.0-1103-aws, linux-image-generic-lpae-hwe-16.04-edge, linux-gcp, linux-aws, linux-image-generic-hwe-16.04, linux-image-azure-edge, linux-image-aws-hwe, linux-image-lowlatency-hwe-16.04-edge, linux-image-oracle, linux-image-4.15.0-1072-oracle, linux-image-generic-hwe-16.04-edge, linux-image-aws-lts-18.04, linux-image-lowlatency, linux-image-4.15.0-1100-gcp, linux-azure-4.15, linux-image-virtual-hwe-16.04, linux-raspi2, linux-image-virtual, linux-image-azure, linux-image-4.15.0-1103-snapdragon, linux-image-oracle-lts-18.04, linux-image-azure-lts-18.04, linux-image-4.15.0-1086-raspi2