Your submission was sent successfully! Close

CVE-2020-25672

Published: 2 November 2020

A memory leak vulnerability was found in Linux kernel in llcp_sock_connect

From the Ubuntu security team

Kiyin (尹亮) discovered that the NFC LLCP protocol implementation in the Linux kernel did not properly deallocate memory in certain error situations. A local attacker could use this to cause a denial of service (memory exhaustion).

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
linux-aws-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal
Released (5.8.0-1038.40~20.04.1)
upstream
Released (5.12~rc7)
impish Does not exist

jammy Does not exist

linux-azure-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.12~rc7)
focal
Released (5.8.0-1036.38~20.04.1)
impish Does not exist

jammy Does not exist

linux-gcp-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal
Released (5.8.0-1035.37~20.04.1)
upstream
Released (5.12~rc7)
impish Does not exist

jammy Does not exist

linux-oracle-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.12~rc7)
focal
Released (5.8.0-1033.34~20.04.1)
impish Does not exist

jammy Does not exist

linux-riscv-5.8
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.12~rc7)
focal
Released (5.8.0-29.31~20.04.1)
impish Does not exist

jammy Does not exist

linux-hwe-5.11
Launchpad, Ubuntu, Debian
focal Not vulnerable
(5.11.0-22.23~20.04.1)
upstream
Released (5.12~rc7)
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

linux-riscv-5.11
Launchpad, Ubuntu, Debian
focal Not vulnerable
(5.11.0-1015.16~20.04.1)
upstream
Released (5.12~rc7)
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

linux-oem-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.13.0-1009.10)
hirsute Does not exist

upstream
Released (5.12~rc7)
impish Does not exist

jammy Does not exist

linux-aws-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1009.9~20.04.2)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-azure-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1007.7~20.04.2)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-oracle-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1008.8~20.04.1)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-bluefield
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

upstream
Released (5.12~rc7)
focal
Released (5.4.0-1012.15)
impish Does not exist

jammy Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

bionic Ignored
(replaced by linux-hwe-5.4)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc7)
xenial
Released (4.15.0-144.148~16.04.1)
jammy Does not exist

linux-hwe-5.4
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-74.83~18.04.1)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-hwe-edge
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
xenial Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-lts-trusty
Launchpad, Ubuntu, Debian
upstream
Released (5.12~rc7)
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

precise Ignored
(was needs-triage ESM criteria)
impish Does not exist

jammy Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
upstream
Released (5.12~rc7)
precise Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

trusty
Released (4.4.0-222.255~14.04.1)
jammy Does not exist

linux-kvm
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

impish Not vulnerable
(5.11.0-1008.8+21.10.1)
focal
Released (5.4.0-1040.41)
groovy
Released (5.8.0-1030.32)
upstream
Released (5.12~rc7)
xenial
Released (4.4.0-1103.112)
jammy Not vulnerable
(5.13.0-1004.4)
bionic
Released (4.15.0-1092.94)
hirsute
Released (5.11.0-1008.8)
linux-aws
Launchpad, Ubuntu, Debian
precise Does not exist

bionic
Released (4.15.0-1103.110)
hirsute
Released (5.11.0-1008.8)
impish Not vulnerable
(5.11.0-1008.8+21.10.1)
trusty
Released (4.4.0-1102.107)
focal
Released (5.4.0-1049.51)
groovy
Released (5.8.0-1038.40)
upstream
Released (5.12~rc7)
xenial
Released (4.4.0-1138.152)
jammy Not vulnerable
(5.13.0-1005.6)
linux-aws-5.0
Launchpad, Ubuntu, Debian
upstream
Released (5.12~rc7)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

jammy Does not exist

linux-aws-5.3
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-aws-5.4
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic
Released (5.4.0-1049.51~18.04.1)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-aws-hwe
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc7)
xenial
Released (4.15.0-1103.110~16.04.1)
jammy Does not exist

linux-azure
Launchpad, Ubuntu, Debian
precise Does not exist

focal
Released (5.4.0-1048.50)
groovy
Released (5.8.0-1036.38)
bionic Ignored
(was needs-triage now end-of-life)
trusty
Released (4.15.0-1115.128~14.04.1)
impish Not vulnerable
(5.11.0-1006.6+21.10.1)
hirsute
Released (5.11.0-1006.6)
upstream
Released (5.12~rc7)
xenial
Released (4.15.0-1115.128~16.04.1)
jammy Not vulnerable
(5.13.0-1006.7)
linux-azure-4.15
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic
Released (4.15.0-1115.128)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-azure-5.3
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-azure-5.4
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1048.50~18.04.1)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-azure-edge
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

focal
Released (5.4.0-1044.47)
bionic Ignored
(was needs-triage now end-of-life)
impish Not vulnerable
(5.11.0-1008.8+21.10.1)
groovy
Released (5.8.0-1035.37)
hirsute
Released (5.11.0-1008.9)
upstream
Released (5.12~rc7)
xenial
Released (4.15.0-1100.113~16.04.1)
jammy Not vulnerable
(5.13.0-1005.6)
linux-gcp-4.15
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (4.15.0-1100.113)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-gcp-5.3
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-gcp-5.4
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic
Released (5.4.0-1044.47~18.04.2)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-gcp-edge
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-gke-4.15
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic Ignored
(was needs-triage now end-of-life)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-gke-5.0
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic Ignored
(was needs-triage now end-of-life)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-gke-5.3
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic Ignored
(was needed now end-of-life)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-oracle
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

hirsute
Released (5.11.0-1007.7)
impish Not vulnerable
(5.11.0-1007.7+21.10.1)
groovy
Released (5.8.0-1033.34)
upstream
Released (5.12~rc7)
xenial
Released (4.15.0-1072.80~16.04.1)
jammy Not vulnerable
(5.13.0-1008.10)
bionic
Released (4.15.0-1072.80)
focal
Released (5.4.0-1046.50)
linux-oracle-5.0
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-oracle-5.3
Launchpad, Ubuntu, Debian
upstream
Released (5.12~rc7)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic Ignored
(was needs-triage now end-of-life)
impish Does not exist

jammy Does not exist

linux-oracle-5.4
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

bionic
Released (5.4.0-1046.50~18.04.2)
linux-oem
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

xenial Ignored
(was needs-triage now end-of-life)
impish Does not exist

bionic Ignored
(was needs-triage now end-of-life)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-oem-5.6
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Ignored
(was needed now end-of-life)
groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-oem-osp1
Launchpad, Ubuntu, Debian
upstream
Released (5.12~rc7)
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic Ignored
(was needs-triage now end-of-life)
jammy Does not exist

linux-raspi
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Not vulnerable
(5.11.0-1009.10+21.10.1)
groovy
Released (5.8.0-1029.32)
upstream
Released (5.12~rc7)
jammy Not vulnerable
(5.13.0-1008.9)
focal
Released (5.4.0-1036.39)
hirsute
Released (5.11.0-1009.10)
linux-raspi2
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

focal Ignored
(replaced by linux-raspi)
groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic
Released (4.15.0-1086.91)
upstream
Released (5.12~rc7)
xenial Ignored
(was needs-triage now end-of-life)
jammy Does not exist

linux-raspi2-5.3
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic Ignored
(was needed now end-of-life)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-raspi-5.4
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

bionic
Released (5.4.0-1036.39~18.04.1)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-riscv
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy
Released (5.8.0-29.31)
impish Not vulnerable
(5.11.0-1009.9+21.10.1)
focal Ignored
(was needs-triage now end-of-life)
upstream
Released (5.12~rc7)
jammy Not vulnerable
(5.13.0-1004.4)
hirsute
Released (5.11.0-1009.9)
linux-snapdragon
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc7)
xenial Ignored
(was needs-triage now end-of-life)
jammy Does not exist

bionic
Released (4.15.0-1103.112)
linux
Launchpad, Ubuntu, Debian
precise Ignored
(was needs-triage ESM criteria)
impish Not vulnerable
(5.11.0-18.19+21.10.1)
trusty Ignored
(was needed ESM criteria)
groovy
Released (5.8.0-59.66)
upstream
Released (5.12~rc7)
xenial
Released (4.4.0-222.255)
bionic
Released (4.15.0-144.148)
focal
Released (5.4.0-74.83)
hirsute
Released (5.11.0-18.19)
jammy Not vulnerable
(5.13.0-19.19)
linux-hwe-5.8
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal
Released (5.8.0-59.66~20.04.1)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-gke-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic
Released (5.4.0-1044.46~18.04.1)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-gkeop-5.4
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

bionic
Released (5.4.0-1016.17~18.04.1)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-dell300x
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

bionic
Released (4.15.0-1022.26)
linux-oem-5.10
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal
Released (5.10.0-1025.26)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-gkeop
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

groovy Does not exist

hirsute Does not exist

focal
Released (5.4.0-1016.17)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-gke
Launchpad, Ubuntu, Debian
impish Does not exist

precise Does not exist

trusty Does not exist

xenial Ignored
(reached end of standard support)
bionic Does not exist

focal
Released (5.4.0-1044.46)
groovy Does not exist

hirsute Does not exist

upstream
Released (5.12~rc7)
jammy Not vulnerable
(5.15.0-1002.2)
linux-ibm
Launchpad, Ubuntu, Debian
impish Does not exist

trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

focal Not vulnerable
(5.4.0-1003.4)
upstream
Released (5.12~rc7)
jammy Not vulnerable
(5.15.0-1002.2)
linux-gcp-5.11
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

hirsute Does not exist

impish Does not exist

focal Not vulnerable
(5.11.0-1009.10~20.04.1)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-oem-5.14
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.14.0-1004.4)
hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-intel-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-azure-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1009.10~20.04.2)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-hwe-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-21.21~20.04.1)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-aws-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Not vulnerable
(5.13.0-1008.9~20.04.2)
impish Does not exist

upstream
Released (5.12~rc7)
jammy Does not exist

linux-fips
Launchpad, Ubuntu, Debian
trusty Does not exist

bionic Does not exist

focal Does not exist

hirsute Does not exist

impish Does not exist

upstream
Released (5.12~rc7)
xenial Not vulnerable
(4.4.0-1073.79)
jammy Does not exist

linux-oracle-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1011.13~20.04.2)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-gcp-5.13
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.13.0-1008.9~20.04.3)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-ibm-5.4
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

focal Does not exist

impish Does not exist

bionic Not vulnerable
(5.4.0-1010.11~18.04.2)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-azure-fde
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

impish Does not exist

focal Not vulnerable
(5.4.0-1063.66+cvm2.2)
upstream
Released (5.12~rc7)
jammy Does not exist

linux-lowlatency
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable

upstream Needs triage

linux-oem-5.17
Launchpad, Ubuntu, Debian
trusty Does not exist

xenial Does not exist

bionic Does not exist

focal Does not exist

impish Does not exist

jammy Not vulnerable

upstream Needs triage