Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

USN-4689-2: Linux kernel vulnerabilities

11 January 2021

Several security issues were fixed in the Linux kernel.

Reduce your security exposure

Ubuntu Pro provides ten-year security coverage to 25,000+ packages in Main and Universe repositories, and it is free for up to five machines.

Learn more about Ubuntu Pro

Releases

Packages

Details

USN-4689-1 fixed vulnerabilities in the NVIDIA graphics drivers.
This update provides the corresponding updates for the NVIDIA Linux
DKMS kernel modules.

Original advisory details:

It was discovered that the NVIDIA GPU display driver for the Linux kernel
contained a vulnerability that allowed user-mode clients to access legacy
privileged APIs. A local attacker could use this to cause a denial of
service or escalate privileges. (CVE-2021-1052)

It was discovered that the NVIDIA GPU display driver for the Linux kernel
did not properly validate a pointer received from userspace in some
situations. A local attacker could use this to cause a denial of service.
(CVE-2021-1053)

Xinyuan Lyu discovered that the NVIDIA GPU display driver for the Linux
kernel did not properly restrict device-level GPU isolation. A local
attacker could use this to cause a denial of service or possibly expose
sensitive information. (CVE-2021-1056)

Reduce your security exposure

Ubuntu Pro provides ten-year security coverage to 25,000+ packages in Main and Universe repositories, and it is free for up to five machines.

Learn more about Ubuntu Pro

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 20.10
Ubuntu 20.04
Ubuntu 18.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

Related notices

  • USN-4689-1: libnvidia-gl-390, nvidia-driver-455, nvidia-384, nvidia-kernel-common-450, libnvidia-cfg1-390, libnvidia-gl-455, libnvidia-fbc1-460, libnvidia-cfg1-460, libnvidia-decode-460, nvidia-utils-440, nvidia-compute-utils-450, libcuda1-384, nvidia-kernel-common-440, nvidia-kernel-common-390, nvidia-headless-no-dkms-450, nvidia-kernel-source-440, nvidia-compute-utils-390, nvidia-utils-455, libnvidia-extra-450, nvidia-headless-no-dkms-440, libnvidia-compute-390, nvidia-compute-utils-460, nvidia-libopencl1-384, libnvidia-decode-440, libnvidia-fbc1-455, nvidia-headless-no-dkms-460, nvidia-kernel-source-455, libnvidia-gl-440, nvidia-driver-390, nvidia-headless-no-dkms-390, nvidia-headless-460, libnvidia-ifr1-450, libnvidia-ifr1-460, xserver-xorg-video-nvidia-460, libnvidia-fbc1-440, nvidia-compute-utils-440, nvidia-driver-440, nvidia-utils-460, nvidia-kernel-source-460, nvidia-384-dev, nvidia-dkms-460, nvidia-compute-utils-455, libnvidia-decode-450, libnvidia-gl-460, libnvidia-compute-440, nvidia-graphics-drivers-460, libnvidia-cfg1-450, libnvidia-common-390, nvidia-utils-390, libnvidia-fbc1-450, nvidia-driver-460, libnvidia-encode-390, nvidia-kernel-source-450, libnvidia-common-440, nvidia-graphics-drivers-390, libnvidia-encode-440, libnvidia-ifr1-390, nvidia-headless-455, nvidia-dkms-455, libnvidia-encode-455, libnvidia-compute-460, libnvidia-extra-460, libnvidia-compute-455, nvidia-driver-450, nvidia-headless-450, libnvidia-ifr1-440, libnvidia-gl-450, nvidia-dkms-440, nvidia-graphics-drivers-450, libnvidia-decode-390, xserver-xorg-video-nvidia-440, nvidia-headless-440, libnvidia-fbc1-390, libnvidia-decode-455, libnvidia-common-460, nvidia-headless-390, nvidia-dkms-390, libnvidia-encode-460, xserver-xorg-video-nvidia-455, libnvidia-common-450, nvidia-kernel-common-455, nvidia-headless-no-dkms-455, libnvidia-compute-450, libnvidia-extra-455, libnvidia-ifr1-455, nvidia-kernel-source-390, libnvidia-cfg1-455, nvidia-opencl-icd-384, libnvidia-cfg1-440, nvidia-kernel-common-460, nvidia-utils-450, libnvidia-common-455, libnvidia-extra-440, xserver-xorg-video-nvidia-390, nvidia-dkms-450, xserver-xorg-video-nvidia-450, libnvidia-encode-450
  • USN-4689-3: libnvidia-common-450-server, nvidia-headless-418-server, nvidia-driver-440-server, libnvidia-encode-440-server, nvidia-graphics-drivers-450-server, libnvidia-decode-450-server, libnvidia-encode-418-server, nvidia-driver-450-server, libnvidia-decode-418-server, nvidia-compute-utils-418-server, nvidia-utils-418-server, libnvidia-decode-440-server, nvidia-headless-no-dkms-440-server, nvidia-driver-418-server, nvidia-dkms-440-server, libnvidia-gl-440-server, nvidia-utils-450-server, nvidia-compute-utils-440-server, nvidia-headless-no-dkms-450-server, nvidia-headless-no-dkms-418-server, nvidia-kernel-source-440-server, libnvidia-extra-450-server, nvidia-dkms-450-server, libnvidia-cfg1-418-server, xserver-xorg-video-nvidia-418-server, nvidia-kernel-common-440-server, libnvidia-common-418-server, nvidia-kernel-source-450-server, libnvidia-ifr1-450-server, nvidia-compute-utils-450-server, nvidia-kernel-common-418-server, nvidia-kernel-source-418-server, nvidia-utils-440-server, libnvidia-compute-450-server, nvidia-headless-440-server, libnvidia-encode-450-server, libnvidia-fbc1-440-server, libnvidia-cfg1-440-server, libnvidia-gl-450-server, libnvidia-cfg1-450-server, nvidia-dkms-418-server, xserver-xorg-video-nvidia-450-server, libnvidia-gl-418-server, nvidia-kernel-common-450-server, libnvidia-ifr1-418-server, nvidia-graphics-drivers-418-server, libnvidia-fbc1-418-server, libnvidia-ifr1-440-server, libnvidia-fbc1-450-server, nvidia-headless-450-server, xserver-xorg-video-nvidia-440-server, libnvidia-compute-440-server, libnvidia-common-440-server, libnvidia-compute-418-server, libnvidia-extra-440-server
  • USN-4689-4: linux-oracle, linux-gcp, linux-image-azure, linux-image-5.8.0-40-lowlatency, linux-image-5.8.0-40-generic, linux-image-5.8.0-1019-gcp, linux-image-lowlatency-hwe-20.04-edge, linux-image-oem-osp1, linux-image-generic-lpae-hwe-16.04-edge, linux-image-4.15.0-134-generic-lpae, linux-image-5.8.0-1019-azure, linux-image-generic-lpae-hwe-16.04, linux-image-generic-hwe-20.04-edge, linux-image-lowlatency-hwe-20.04, linux-image-generic-lpae-hwe-18.04-edge, linux-image-generic-64k-hwe-20.04, linux-image-generic-lpae-hwe-20.04-edge, linux-hwe-5.4, linux-image-virtual-hwe-18.04, linux-image-generic-64k, linux-image-virtual-hwe-18.04-edge, linux-image-5.8.0-40-generic-lpae, linux-image-oracle, linux-image-generic-hwe-20.04, linux-image-generic-hwe-16.04-edge, linux-image-virtual-hwe-20.04-edge, linux-image-generic, linux-image-virtual-hwe-20.04, linux-image-generic-lpae-hwe-18.04, linux-image-gcp, linux-image-snapdragon-hwe-18.04-edge, linux-image-5.4.0-64-generic-lpae, linux-image-aws, linux-image-4.15.0-134-lowlatency, linux, linux-image-5.4.0-64-generic, linux-image-virtual, linux-image-generic-hwe-16.04, linux-image-lowlatency-hwe-16.04-edge, linux-image-generic-hwe-18.04-edge, linux-azure, linux-image-virtual-hwe-16.04-edge, linux-image-lowlatency-hwe-16.04, linux-image-generic-lpae, linux-image-generic-64k-hwe-20.04-edge, linux-image-5.8.0-1017-oracle, linux-image-virtual-hwe-16.04, linux-image-5.4.0-64-lowlatency, linux-image-snapdragon-hwe-18.04, linux-image-generic-lpae-hwe-20.04, linux-image-5.8.0-1020-aws, linux-image-gke, linux-image-generic-hwe-18.04, linux-image-lowlatency-hwe-18.04-edge, linux-hwe-5.8, linux-image-oem-20.04, linux-image-oem, linux-image-4.15.0-134-generic, linux-image-lowlatency-hwe-18.04, linux-aws, linux-image-5.8.0-40-generic-64k, linux-image-lowlatency