Your submission was sent successfully! Close

CVE-2014-9650

Published: 27 January 2015

CRLF injection vulnerability in the management plugin in RabbitMQ 2.1.0 through 3.4.x before 3.4.1 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via the download parameter to api/definitions.

Priority

Low

Status

Package Release Status
rabbitmq-server
Launchpad, Ubuntu, Debian
Upstream
Released (3.4.2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.4.2-2)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(3.4.2-2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://github.com/rabbitmq/rabbitmq-management/commit/b5a5fc31bd49ad821a655ea9e2fe920d670a62ad