Your submission was sent successfully! Close

USN-772-1: MPFR vulnerability

7 May 2009

MPFR vulnerability

Releases

Packages

Details

It was discovered that MPFR improperly handled string lengths in its print
routines. If a user or automated system were tricked into processing
specially crafted data with applications linked against MPFR, an attacker
could cause a denial of service or execute arbitrary code with privileges
of the user invoking the program.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.04

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References