Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

USN-5651-1: strongSwan vulnerability

3 October 2022

strongSwan could be made do denial of service if it received a specially crafted certificate.

Reduce your security exposure

Ubuntu Pro provides ten-year security coverage to 25,000+ packages in Main and Universe repositories, and it is free for up to five machines.

Learn more about Ubuntu Pro

Releases

Packages

Details

Lahav Schlesinger discovered that strongSwan incorrectly handled certain OCSP URIs and
and CRL distribution points (CDP) in certificates. A remote attacker could
possibly use this issue to initiate IKE_SAs and send crafted certificates
that contain URIs pointing to servers under their control, which can lead
to a denial-of-service attack.

Reduce your security exposure

Ubuntu Pro provides ten-year security coverage to 25,000+ packages in Main and Universe repositories, and it is free for up to five machines.

Learn more about Ubuntu Pro

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 22.04
Ubuntu 20.04
Ubuntu 18.04

In general, a standard system update will make all the necessary changes.

References

Related notices

  • USN-5651-2: libstrongswan-extra-plugins, strongswan-plugin-error-notify, strongswan-plugin-ipseckey, strongswan-plugin-eap-gtc, strongswan-tnc-ifmap, strongswan-plugin-pubkey, strongswan-tnc-base, strongswan-plugin-dnskey, strongswan-tnc-client, strongswan-plugin-kernel-libipsec, strongswan-plugin-eap-sim, strongswan-plugin-lookip, strongswan-charon, strongswan-plugin-sql, strongswan-plugin-agent, strongswan-plugin-ldap, strongswan-plugin-soup, strongswan-plugin-unbound, strongswan-plugin-certexpire, strongswan-plugin-ntru, strongswan-plugin-eap-radius, strongswan-tnc-server, strongswan-plugin-eap-dynamic, strongswan-plugin-eap-sim-pcsc, strongswan-plugin-led, strongswan-tnc-pdp, strongswan-ike, strongswan-plugin-eap-aka-3gpp2, strongswan-plugin-unity, strongswan-plugin-gcrypt, strongswan-plugin-pkcs11, strongswan-plugin-eap-mschapv2, strongswan-plugin-radattr, libstrongswan, strongswan, strongswan-plugin-openssl, strongswan-plugin-fips-prf, charon-cmd, strongswan-plugin-xauth-pam, strongswan-ikev2, strongswan-plugin-xauth-eap, strongswan-plugin-eap-tnc, strongswan-plugin-load-tester, libcharon-extra-plugins, strongswan-plugin-coupling, strongswan-plugin-dnscert, strongswan-plugin-eap-md5, strongswan-plugin-af-alg, strongswan-plugin-eap-aka, strongswan-plugin-farp, strongswan-plugin-mysql, strongswan-plugin-sshkey, strongswan-plugin-systime-fix, strongswan-plugin-whitelist, libstrongswan-standard-plugins, strongswan-plugin-xauth-generic, strongswan-plugin-xauth-noauth, strongswan-libcharon, strongswan-plugin-eap-simaka-sql, strongswan-plugin-dhcp, strongswan-plugin-eap-peap, strongswan-plugin-sqlite, strongswan-starter, strongswan-plugin-curl, strongswan-ikev1, strongswan-nm, strongswan-plugin-attr-sql, strongswan-plugin-eap-simaka-reauth, strongswan-plugin-duplicheck, strongswan-plugin-eap-tls, strongswan-pt-tls-client, strongswan-plugin-eap-simaka-pseudonym, strongswan-plugin-gmp, strongswan-plugin-eap-ttls, strongswan-plugin-eap-sim-file, strongswan-plugin-pgp