Your submission was sent successfully! Close

USN-5462-2: Ruby vulnerability

6 June 2022

Ruby could be made to crash or read sensitive information when processing certain input.

Releases

Packages

  • ruby2.3 - Object-oriented scripting language

Details

USN-5462-1 fixed several vulnerabilities in Ruby. This update provides
the corresponding CVE-2022-28739 update for ruby2.3 on Ubuntu 16.04 ESM.

Original advisory details:

It was discovered that Ruby incorrectly handled certain inputs.
An attacker could possibly use this issue to expose sensitive information.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04

In general, a standard system update will make all the necessary changes.

References

Related notices

  • USN-5462-1: libruby2.7, ruby2.5-dev, ruby2.5, ruby2.7-dev, ruby2.7-doc, ruby2.5-doc, ruby3.0, ruby3.0-dev, libruby2.5, ruby2.7, ruby3.0-doc, libruby3.0