Your submission was sent successfully! Close

USN-5222-1: Apache Log4j 2 vulnerabilities

11 January 2022

Several security issues were fixed in Apache Log4j 2.

Releases

Packages

Details

It was discovered that Apache Log4j 2 was vulnerable to remote code
execution (RCE) attack when configured to use a JDBC Appender with a
JNDI LDAP data source URI. A remote attacker could possibly use this issue to
cause a crash, leading to a denial of service. (CVE-2021-44832)

Hideki Okamoto and Guy Lederfein discovered that Apache Log4j 2 did not
protect against infinite recursion in lookup evaluation. A remote attacker
could possibly use this issue to cause Apache Log4j 2 to crash, leading to
a denial of service. This issue only affected Ubuntu 18.04 LTS.
(CVE-2021-45105)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 21.10
Ubuntu 21.04
Ubuntu 20.04
Ubuntu 18.04

In general, a standard system update will make all the necessary changes.

Related notices

  • USN-5203-1: liblog4j2-java-doc, apache-log4j2, liblog4j2-java