Your submission was sent successfully! Close

CVE-2021-44832

Published: 28 December 2021

Apache Log4j2 versions 2.0-beta7 through 2.17.0 (excluding security fix releases 2.3.2 and 2.12.4) are vulnerable to a remote code execution (RCE) attack when a configuration uses a JDBC Appender with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI data source names to the java protocol in Log4j2 versions 2.17.1, 2.12.4, and 2.3.2.

Priority

Medium

CVSS 3 base score: 6.6

Status

Package Release Status
apache-log4j2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri)
Released (2.17.1-0.21.10.1)
Ubuntu 21.04 (Hirsute Hippo)
Released (2.17.1-0.21.04.1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.17.1-0.20.04.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.12.4-0ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist