Your submission was sent successfully! Close

CVE-2021-45105

Published: 19 December 2021

Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3 and 2.3.1) did not protect from uncontrolled recursion from self-referential lookups. This allows an attacker with control over Thread Context Map data to cause a denial of service when a crafted string is interpreted. This issue was fixed in Log4j 2.17.0, 2.12.3, and 2.3.1.

Priority

Medium

CVSS 3 base score: 5.9

Status

Package Release Status
apache-log4j2
Launchpad, Ubuntu, Debian
Upstream
Released (2.17.0-1)
Ubuntu 21.10 (Impish Indri)
Released (2.17.0-0.21.10.1)
Ubuntu 21.04 (Hirsute Hippo)
Released (2.17.0-0.21.04.1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.17.0-0.20.04.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.12.4-0ubuntu0.1)
Patches:
Upstream: https://github.com/apache/logging-log4j2/commit/806023265f8c905b2dd1d81fd2458f64b2ea0b5e (2.x)
Upstream: https://github.com/apache/logging-log4j2/commit/bf7e916df6335713fe2219c7b3b523fb509deabc (2.12.x)