USN-5043-1: Exiv2 vulnerabilities

17 August 2021

Several security issues were fixed in Exiv2.

Releases

Packages

  • exiv2 - EXIF/IPTC/XMP metadata manipulation tool

Details

It was discovered that Exiv2 incorrectly handled certain image files.
An attacker could possibly use this issue to cause a denial of service.
(CVE-2021-32815, CVE-2021-34334, CVE-2021-37620, CVE-2021-37622)

It was discovered that Exiv2 incorrectly handled certain image files.
An attacker could possibly use this issue to cause a denial of service.
These issues only affected Ubuntu 20.04 LTS and Ubuntu 21.04.
(CVE-2021-34335, CVE-2021-37615, CVE-2021-37616, CVE-2021-37618,
CVE-2021-37619, CVE-2021-37621, CVE-2021-37623)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 21.04
Ubuntu 20.04
Ubuntu 18.04
Ubuntu 16.04

In general, a standard system update will make all the necessary changes.