Your submission was sent successfully! Close

USN-4692-1: tar vulnerabilities

13 January 2021

Several security issues were fixed in tar.

Releases

Packages

  • tar - GNU version of the tar archiving utility

Details

Chris Siebenmann discovered that tar incorrectly handled extracting files
resized during extraction when invoked with the --sparse flag. An attacker
could possibly use this issue to cause a denial of service. This issue
only affected Ubuntu 12.04 ESM, Ubuntu 14.04 ESM, Ubuntu 16.04 LTS and
Ubuntu 18.04 LTS. (CVE-2018-20482)

Daniel Axtens discovered that tar incorrectly handled certain malformed
tar files. If a user or automated system were tricked into processing a
specially crafted tar archive, a remote attacker could use this issue to
cause tar to crash, resulting in a denial of service. (CVE-2019-9923)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 20.10
Ubuntu 20.04
Ubuntu 18.04
Ubuntu 16.04
Ubuntu 14.04
Ubuntu 12.04

In general, a standard system update will make all the necessary changes.