USN-4682-1: WavPack vulnerability

06 January 2021

WavPack could be made to execute arbitrary code or crash if it received a specially crafted WAV file.

Releases

Packages

  • wavpack - audio codec (lossy and lossless) - encoder and decoder

Details

It was discovered that WavPack incorrectly handled certain WAV files.
An attacker could possibly use this issue to execute arbitrary code or
cause a crash.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 20.10
Ubuntu 20.04
Ubuntu 18.04

In general, a standard system update will make all the necessary changes.

References