Your submission was sent successfully! Close

USN-4134-2: IBus regression

23 September 2019

USN 4134-1 introduced a regression in IBus.

Releases

Packages

  • ibus - Intelligent Input Bus - core

Details

USN-4134-1 fixed a vulnerability in IBus. The security fix introduced a
regression when being used with Qt applications. This update reverts the
security fix pending further investigation.

Original advisory details:

Simon McVittie discovered that IBus did not enforce appropriate access
controls on its private D-Bus socket. A local unprivileged user who
discovers the IBus socket address of another user could exploit this to
capture the key strokes of the other user.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
Ubuntu 18.04
Ubuntu 16.04

After a standard system update you need to reboot your computer to make
all the necessary changes.