USN-4110-1: Dovecot vulnerability

28 August 2019

Dovecot could be made to crash or execute arbitrary code if it received a specially crafted data.

Releases

Packages

  • dovecot - IMAP and POP3 email server

Details

Nick Roessler and Rafi Rubin discovered that Dovecot incorrectly
handled certain data. An attacker could possibly use this issue
to cause a denial of service or execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
Ubuntu 18.04
Ubuntu 16.04

In general, a standard system update will make all the necessary changes.

References

Related notices

  • USN-4110-2: dovecot-lmtpd, dovecot-managesieved, dovecot-common, dovecot-pgsql, dovecot-sieve, dovecot-solr, dovecot-postfix, dovecot, dovecot-mysql, dovecot-sqlite, mail-stack-delivery, dovecot-core, dovecot-gssapi, dovecot-pop3d, dovecot-dev, dovecot-imapd, dovecot-ldap
  • USN-4110-3: dovecot-lmtpd, dovecot-managesieved, dovecot-solr, dovecot-pgsql, dovecot-sieve, dovecot-auth-lua, dovecot, dovecot-mysql, dovecot-sqlite, mail-stack-delivery, dovecot-core, dovecot-gssapi, dovecot-submissiond, dovecot-pop3d, dovecot-dev, dovecot-lucene, dovecot-imapd, dovecot-ldap
  • USN-4110-4: dovecot-lmtpd, dovecot-managesieved, dovecot-common, dovecot-pgsql, dovecot-sieve, dovecot-solr, dovecot-postfix, dovecot, dovecot-mysql, dovecot-sqlite, mail-stack-delivery, dovecot-core, dovecot-gssapi, dovecot-pop3d, dovecot-dev, dovecot-imapd, dovecot-ldap