Your submission was sent successfully! Close

USN-3837-1: poppler vulnerabilities

04 December 2018

Several security issues were fixed in poppler.

Releases

Packages

Details

It was discovered that poppler incorrectly handled certain PDF files.
An attacker could possibly use this issue to cause a denial of service.
(CVE-2018-16646, CVE-2018-19058, CVE-2018-19059, CVE-2018-19060)

It was discovered that poppler incorrectly handled certain PDF files.
An attacker could possibly use this issue to cause a denial of service.
This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS.
(CVE-2018-19149)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.10
Ubuntu 18.04
Ubuntu 16.04
Ubuntu 14.04

In general, a standard system update will make all the necessary changes.

Related notices

  • USN-3837-2: libpoppler-qt4-dev, libpoppler-qt5-dev, libpoppler-glib-dev, libpoppler-qt5-1, libpoppler44, libpoppler79, libpoppler-dev, libpoppler-qt4-4, gir1.2-poppler-0.18, libpoppler73, libpoppler-cpp0, libpoppler-cpp0v5, libpoppler-private-dev, libpoppler-glib-doc, poppler-utils, libpoppler-cpp-dev, poppler, libpoppler58, libpoppler-glib8