Your submission was sent successfully! Close

USN-3353-3: Heimdal vulnerability

24 July 2017

Heimdal could allow unintended access to network services.

Releases

Packages

  • heimdal - Heimdal Kerberos Network Authentication Protocol

Details

USN-3353-1 fixed a vulnerability in Heimdal. This update provides
the corresponding updade for Ubuntu 12.04 ESM.

Original advisory details:

Jeffrey Altman, Viktor Dukhovni, and Nicolas Williams discovered
that Heimdal clients incorrectly trusted unauthenticated portions
of Kerberos tickets. A remote attacker could use this to impersonate
trusted network services or perform other attacks.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 12.04

After a standard system update you need to restart any applications
using Heimdal libraries to make all the necessary changes.

References

Related notices

  • USN-3353-4: samba, libsmbclient
  • USN-3353-1: heimdal-clients, libhdb9-heimdal, libkadm5clnt7-heimdal, libotp0-heimdal, libkrb5-26-heimdal, heimdal-multidev, libheimbase1-heimdal, heimdal-kcm, heimdal-servers-x, libsl0-heimdal, heimdal, heimdal-kdc, heimdal-dev, libheimntlm0-heimdal, libhcrypto4-heimdal, libasn1-8-heimdal, heimdal-servers, libkafs0-heimdal, libwind0-heimdal, libhx509-5-heimdal, libkdc2-heimdal, libroken18-heimdal, heimdal-docs, libgssapi3-heimdal, heimdal-clients-x, libkadm5srv8-heimdal
  • USN-3353-2: winbind, samba, libsmbsharemodes-dev, samba-vfs-modules, samba-doc, libwbclient-dev, libsmbclient-dev, samba-dsdb-modules, libpam-winbind, libsmbclient, samba-libs, samba-testsuite, libwbclient0, samba-dev, libsmbsharemodes0, smbclient, samba-common, ctdb, libnss-winbind, python-samba, registry-tools, libparse-pidl-perl, libpam-smbpass, samba-common-bin