Your submission was sent successfully! Close

USN-1229-1: PostgreSQL vulnerability

13 October 2011

PostgreSQL incorrectly handled blowfish passwords.

Releases

Packages

Details

It was discovered that the blowfish algorithm in the pgcrypto module
incorrectly handled certain 8-bit characters, resulting in the password
hashes being easier to crack than expected. An attacker who could obtain
the password hashes would be able to recover the plaintext with less
effort.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.04
Ubuntu 11.04
Ubuntu 10.10
Ubuntu 10.04

In general, a standard system update will make all the necessary changes.

References

Related notices

  • USN-1231-1: php5-cli, php5, php5-cgi, php5-common, libapache2-mod-php5