CVE-2011-2483

Published: 25 August 2011

crypt_blowfish before 1.1, as used in PHP before 5.3.7 on certain platforms, PostgreSQL before 8.4.9, and other products, does not properly handle 8-bit characters, which makes it easier for context-dependent attackers to determine a cleartext password by leveraging knowledge of a password hash.

Priority

Medium

Status

Package Release Status
john
Launchpad, Ubuntu, Debian
Upstream
Released (1.7.8-1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [1.7.8-1])
Patches:
Other: http://www.openwall.com/lists/john-dev/2011/06/19/3
libcrypt-eksblowfish-perl
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected)
php5
Launchpad, Ubuntu, Debian
Upstream
Released (5.3.6-13, 5.3.8-1)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(5.3.6-13ubuntu2)
postgresql-8.2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

postgresql-8.3
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

postgresql-8.4
Launchpad, Ubuntu, Debian
Upstream Pending
(8.4.9)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

postgresql-9.1
Launchpad, Ubuntu, Debian
Upstream Pending
(9.1~rc1-2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [9.1~rc1-2])
Patches:
Upstream: http://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=ca59dfa6f727fe3bf3a01904ec30e87f7fa5a67e