Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2024-38475

Published: 1 July 2024

Improper escaping of output in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to map URLs to filesystem locations that are permitted to be served by the server but are not intentionally/directly reachable by any URL, resulting in code execution or source code disclosure. Substitutions in server context that use a backreferences or variables as the first segment of the substitution are affected.  Some unsafe RewiteRules will be broken by this change and the rewrite flag "UnsafePrefixStat" can be used to opt back in once ensuring the substitution is appropriately constrained.

Notes

AuthorNote
mdeslaur
same fix as CVE-2024-28474

Priority

Medium

Status

Package Release Status
apache2
Launchpad, Ubuntu, Debian
bionic Needs triage

focal
Released (2.4.41-4ubuntu3.19)
jammy
Released (2.4.52-1ubuntu4.10)
mantic
Released (2.4.57-2ubuntu2.5)
noble
Released (2.4.58-1ubuntu8.2)
trusty Needs triage

upstream
Released (2.4.60-1)
xenial Needs triage

Patches:
upstream: https://svn.apache.org/viewvc?view=revision&revision=1918561
upstream: https://github.com/apache/httpd/commit/1feb5e04a4f7b5f3f13cd40f9635144319dcf24a