Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2024-25112

Published: 12 February 2024

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. A denial-of-service was found in Exiv2 version v0.28.1: an unbounded recursion can cause Exiv2 to crash by exhausting the stack. The vulnerable function, `QuickTimeVideo::multipleEntriesDecoder`, was new in v0.28.0, so Exiv2 versions before v0.28 are _not_ affected. The denial-of-service is triggered when Exiv2 is used to read the metadata of a crafted video file. This bug is fixed in version v0.28.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Priority

Medium

Status

Package Release Status
exiv2
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
xenial Not vulnerable

bionic Not vulnerable

focal Not vulnerable

jammy Not vulnerable

mantic Not vulnerable
(0.27.6-1)
upstream
Released (v0.28.2)