Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2024-24549

Published: 13 March 2024

Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

Priority

Medium

Status

Package Release Status
tomcat10
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Needs triage

upstream Needs triage

Patches:
upstream: https://github.com/apache/tomcat/commit/d07c82194edb69d99b438828fe2cbfadbb207843

tomcat6
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

trusty Needs triage

upstream Needs triage

xenial Needs triage

tomcat7
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Does not exist

jammy Does not exist

mantic Does not exist

trusty Needs triage

upstream Needs triage

xenial Needs triage

tomcat8
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Does not exist

jammy Does not exist

mantic Does not exist

upstream Needs triage

xenial Needs triage

tomcat9
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Needs triage

jammy Needs triage

mantic Needs triage

upstream Needs triage

Patches:

upstream: https://github.com/apache/tomcat/commit/8e03be9f2698f2da9027d40b9e9c0c9429b74dc0