Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-4900

Published: 2 November 2023

A vulnerability was found in PHP where setting the environment variable PHP_CLI_SERVER_WORKERS to a large value leads to a heap buffer overflow.

Notes

AuthorNote
Priority reason:
Crash in command line tool only.
sbeattie
PEAR issues should go against php-pear as of xenial
leosilva
php7.2 in bionic and 7.4 in focal hasn't code affected.
rodrigo-zaiden
affected code seems like was added in commit 82effb3f,
that is included with php7.4.

Priority

Low

Cvss 3 Severity Score

5.5

Score breakdown

Status

Package Release Status
php8.1
Launchpad, Ubuntu, Debian
kinetic Ignored
(end of life, was needed)
bionic Does not exist

focal Does not exist

jammy Needed

trusty Does not exist

upstream Needs triage

xenial Does not exist

lunar Not vulnerable
(8.1.12-1ubuntu4)
mantic Does not exist

Patches:
upstream: https://github.com/php/php-src/commit/789a37f14405e2d1a05a76c9fb4ed2d49d4580d5
php7.2
Launchpad, Ubuntu, Debian
jammy Does not exist

kinetic Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

bionic Not vulnerable
(code not present)
focal Does not exist

php7.4
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable
(code not present)
jammy Does not exist

kinetic Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

php5
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Does not exist

kinetic Does not exist

upstream Needs triage

xenial Does not exist

trusty Not vulnerable
(code not present)
php7.0
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Does not exist

kinetic Does not exist

trusty Does not exist

upstream Needs triage

xenial Not vulnerable
(code not present)

Severity score breakdown

Parameter Value
Base score 5.5
Attack vector Local
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H