Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-41974

Published: 24 October 2022

multipath-tools 0.7.0 through 0.9.x before 0.9.2 allows local users to obtain root access, as exploited alone or in conjunction with CVE-2022-41973. Local users able to write to UNIX domain sockets can bypass access controls and manipulate the multipath setup. This can lead to local privilege escalation to root. This occurs because an attacker can repeat a keyword, which is mishandled because arithmetic ADD is used instead of bitwise OR.

Notes

AuthorNote
alexmurray
introduced in version 0.7.0 via commit 9acda0c but earlier versions do no authorization checks at all and are then technically also vulnerable
rodrigo-zaiden
earlier versions are not getting a code fix for this and
applying one without upstream support does not seem feasible and can add
too much risks.

Priority

Medium

Cvss 3 Severity Score

7.8

Score breakdown

Status

Package Release Status
multipath-tools
Launchpad, Ubuntu, Debian
bionic
Released (0.7.4-2ubuntu3.2)
focal
Released (0.8.3-1ubuntu2.1)
jammy
Released (0.8.8-1ubuntu1.22.04.1)
kinetic
Released (0.8.8-1ubuntu1.22.10.1)
trusty Ignored
(fix not applicable)
upstream
Released (0.9.2)
xenial Ignored
(fix not applicable)
Patches:
upstream: https://github.com/opensvc/multipath-tools/commit/f812466f68b8e020818c6454d7b7a7e278bc99f6

Severity score breakdown

Parameter Value
Base score 7.8
Attack vector Local
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H