Your submission was sent successfully! Close

CVE-2022-3170

Published: 13 September 2022

An out-of-bounds access issue was found in the Linux kernel sound subsystem. It could occur when the 'id->name' provided by the user did not end with '\0'. A privileged local user could pass a specially crafted name through ioctl() interface and crash the system or potentially escalate their privileges on the system.

Notes

AuthorNote
amurray
Only affects kernel versions >= 6.0-rc1 and < 6.0-rc4
Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

jammy Not vulnerable

precise Not vulnerable

trusty Not vulnerable

upstream Not vulnerable
(debian: Vulnerable code not present)
xenial Not vulnerable

Patches:
Introduced by

c27e1efb61c545f36c450ef60862df9251d239a4

Fixed by 6ab55ec0a938c7f943a4edba3d6514f775983887
Introduced by

c27e1efb61c545f36c450ef60862df9251d239a4

Fixed by 5934d9a0383619c14df91af8fd76261dc3de2f5f
linux-aws
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

jammy Not vulnerable

trusty Not vulnerable

upstream Not vulnerable

xenial Not vulnerable

linux-aws-5.0
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-aws-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-aws-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-aws-5.15
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-aws-5.3
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-aws-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-aws-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-aws-hwe
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Not vulnerable

linux-azure
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

jammy Not vulnerable

trusty Not vulnerable

upstream Not vulnerable

xenial Not vulnerable

linux-azure-4.15
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-azure-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-azure-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-azure-5.15
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-azure-5.3
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-azure-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-azure-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-azure-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-azure-fde
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Not vulnerable

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-bluefield
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-dell300x
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-fips
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gcp
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

jammy Not vulnerable

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Not vulnerable

linux-gcp-4.15
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gcp-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gcp-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gcp-5.15
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gcp-5.3
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gcp-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gcp-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gke
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Not vulnerable

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gke-4.15
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gke-5.0
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gke-5.15
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gke-5.3
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gke-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gkeop
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Not vulnerable

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-gkeop-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-hwe
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Not vulnerable

linux-hwe-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-hwe-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-hwe-5.15
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-hwe-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-hwe-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Not vulnerable

linux-ibm
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Not vulnerable

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-ibm-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-intel-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-intel-iotg
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Not vulnerable

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-intel-iotg-5.15
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-kvm
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

jammy Not vulnerable

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Not vulnerable

linux-lowlatency
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Not vulnerable

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-lowlatency-hwe-5.15
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Does not exist

trusty Not vulnerable

upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oem
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oem-5.10
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oem-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oem-5.14
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oem-5.17
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

jammy Not vulnerable

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oem-5.6
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oem-osp1
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oracle
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

jammy Not vulnerable

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Not vulnerable

linux-oracle-5.0
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oracle-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oracle-5.13
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oracle-5.3
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oracle-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-oracle-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-raspi
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Not vulnerable

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-raspi-5.4
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-raspi2
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-raspi2-5.3
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-riscv
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Not vulnerable

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-riscv-5.11
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-riscv-5.8
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Not vulnerable

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)
linux-snapdragon
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Does not exist

jammy Does not exist

trusty Ignored
(out of standard support)
upstream Not vulnerable

xenial Ignored
(out of standard support)