Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-23647

Published: 18 February 2022

Prism is a syntax highlighting library. Starting with version 1.14.0 and prior to version 1.27.0, Prism's command line plugin can be used by attackers to achieve a cross-site scripting attack. The command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code. Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted. This bug has been fixed in v1.27.0. As a workaround, do not use the command line plugin on untrusted inputs, or sanitize all code blocks (remove all HTML code text) from all code blocks that use the command line plugin.

Priority

Medium

Cvss 3 Severity Score

6.1

Score breakdown

Status

Package Release Status
node-prismjs
Launchpad, Ubuntu, Debian
focal Needs triage

impish Ignored
(end of life)
jammy Needs triage

kinetic Ignored
(end of life, was needs-triage)
lunar Not vulnerable
(1.29.0+dfsg+~1.26.0-1)
mantic Not vulnerable
(1.29.0+dfsg+~1.26.0-1)
noble Not vulnerable
(1.29.0+dfsg+~1.26.0-1)
trusty Ignored
(end of standard support)
upstream
Released (1.27.0+dfsg+~1.26.0-1)
xenial Ignored
(end of standard support)

Severity score breakdown

Parameter Value
Base score 6.1
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Changed
Confidentiality Low
Integrity impact Low
Availability impact None
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N