Your submission was sent successfully! Close

CVE-2021-33829

Published: 9 June 2021

A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --!> is mishandled.

Priority

Medium

CVSS 3 base score: 6.1

Status

Package Release Status
ckeditor
Launchpad, Ubuntu, Debian
bionic
Released (4.5.7+dfsg-2ubuntu0.18.04.1)
focal
Released (4.12.1+dfsg-1ubuntu0.1)
groovy Needed

hirsute Ignored
(reached end-of-life)
impish Not vulnerable
(4.16.0+dfsg-2)
jammy Not vulnerable
(4.16.0+dfsg-2)
trusty Does not exist

upstream
Released (4.16.0+dfsg-2)
xenial Ignored
(out of standard support)