Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2021-32714

Published: 7 July 2021

hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks." The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a `Transfer-Encoding` header or ensure any upstream proxy rejects `Transfer-Encoding` chunk sizes greater than what fits in 64-bit unsigned integers.

Priority

Medium

Cvss 3 Severity Score

9.1

Score breakdown

Status

Package Release Status
rust-hyper
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Needed

groovy Does not exist

hirsute Ignored
(end of life)
impish Ignored
(end of life)
jammy Does not exist

kinetic Ignored
(end of life, was needs-triage)
lunar Not vulnerable
(0.14.19-1)
mantic Not vulnerable
(0.14.19-1)
noble Not vulnerable
(0.14.19-1)
trusty Does not exist

upstream
Released (0.14.10)
xenial Ignored
(end of standard support)

Severity score breakdown

Parameter Value
Base score 9.1
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H