CVE-2021-3246

Published: 20 July 2021

A heap buffer overflow vulnerability in msadpcm_decode_block of libsndfile 1.0.30 allows attackers to execute arbitrary code via a crafted WAV file.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
libsndfile
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo)
Released (1.0.31-1ubuntu1.1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (1.0.28-7ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.0.28-4ubuntu0.18.04.2)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.0.25-10ubuntu0.16.04.3+esm1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.0.25-7ubuntu2.2+esm2)
Patches:
Upstream: https://github.com/libsndfile/libsndfile/commit/deb669ee8be55a94565f6f8a6b60890c2e7c6f32