CVE-2021-27291

Published: 17 March 2021

In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
eric
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Needed

Ubuntu 20.10 (Groovy Gorilla) Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 LTS (Xenial Xerus) Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

pygments
Launchpad, Ubuntu, Debian
Upstream
Released (2.7.4)
Ubuntu 21.04 (Hirsute Hippo)
Released (2.7.1+dfsg-2ubuntu1)
Ubuntu 20.10 (Groovy Gorilla)
Released (2.3.1+dfsg-4ubuntu0.2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.3.1+dfsg-1ubuntu2.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.2.0+dfsg-1ubuntu0.2)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.1+dfsg-1ubuntu0.2)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://github.com/pygments/pygments/commit/2e7e8c4a7b318f4032493773732754e418279a14