Your submission was sent successfully! Close

CVE-2021-23336

Published: 15 February 2021

The package python/cpython from 0 and before 3.6.13, from 3.7.0 and before 3.7.10, from 3.8.0 and before 3.8.8, from 3.9.0 and before 3.9.2 are vulnerable to Web Cache Poisoning via urllib.parse.parse_qsl and urllib.parse.parse_qs by using a vector called parameter cloaking. When the attacker can separate query parameters using a semicolon (;), they can cause a difference in the interpretation of the request between the proxy (running with default configuration) and the server. This can result in malicious requests being cached as completely safe ones, as the proxy would usually not see the semicolon as a separator, and therefore would not include it in a cache key of an unkeyed parameter.

Priority

Low

CVSS 3 base score: 5.9

Status

Package Release Status
python-django
Launchpad, Ubuntu, Debian
bionic
Released (1:1.11.11-1ubuntu1.11)
focal
Released (2:2.2.12-1ubuntu0.4)
groovy
Released (2:2.2.16-1ubuntu0.2)
hirsute
Released (2.2.19-1)
impish
Released (2.2.19-1)
jammy
Released (2.2.19-1)
precise Does not exist

trusty Not vulnerable
(code not present)
upstream
Released (2.2.19)
xenial Not vulnerable
(code not present)
python2.7
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

groovy Ignored
(reached end-of-life)
hirsute Ignored
(reached end-of-life)
impish Ignored

jammy Ignored

precise Ignored

trusty Ignored

upstream Needs triage

xenial Ignored

python3.4
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Needs triage

upstream Needs triage

xenial Does not exist

python3.5
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Ignored

upstream Needs triage

xenial Ignored

python3.6
Launchpad, Ubuntu, Debian
bionic Ignored

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (3.6.13)
xenial Does not exist

python3.7
Launchpad, Ubuntu, Debian
bionic Ignored

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (3.7.10)
xenial Does not exist

python3.8
Launchpad, Ubuntu, Debian
bionic Ignored

focal Ignored

groovy Ignored
(reached end-of-life)
hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (3.8.8)
xenial Does not exist

python3.9
Launchpad, Ubuntu, Debian
bionic Does not exist

focal
Released (3.9.5-3~20.04.1)
groovy
Released (3.9.5-3~20.10.1)
hirsute Not vulnerable
(3.9.2-1)
impish Not vulnerable
(3.9.2-1)
jammy Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (3.9.2)
xenial Does not exist

Notes

AuthorNote
mdeslaur
fixing this in stable releases will break compatibility with
existing applications. Marking as low priority. We may decide
not to fix this at all in stable releases in the future.
rodrigo-zaiden
Decided not to fix. The proposed fixes could possibly
break existing python packages in Ubuntu. There are
known regressions to this CVE, such as:
https://giters.com/scrapy/w3lib/issues/164

References

Bugs