Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2021-0646

Published: 17 August 2021

In sqlite3_str_vappendf of sqlite3.c, there is a possible out of bounds write due to improper input validation. This could lead to local escalation of privilege if the user can also inject a printf into a privileged process's SQL with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-9 Android-10 Android-11 Android-8.1Android ID: A-153352319

Notes

AuthorNote
mdeslaur
this is an android-specific CVE which corresponds to
CVE-2020-13434 in sqlite3

Priority

Medium

Cvss 3 Severity Score

7.8

Score breakdown

Status

Package Release Status
sqlite
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

hirsute Not vulnerable

impish Not vulnerable

jammy Not vulnerable

trusty Not vulnerable

upstream Not vulnerable

xenial Not vulnerable

sqlite3
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

hirsute Not vulnerable

impish Not vulnerable

jammy Not vulnerable

trusty Not vulnerable

upstream Not vulnerable

xenial Not vulnerable

Patches:
upstream: https://sqlite.org/src/info/d08d3405878d394e

Severity score breakdown

Parameter Value
Base score 7.8
Attack vector Local
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H