CVE-2020-14155

Published: 15 June 2020

libpcre in PCRE before 8.44 allows an integer overflow via a large number after a (?C substring.

Priority

Negligible

CVSS 3 base score: 5.3

Status

Package Release Status
pcre3
Launchpad, Ubuntu, Debian
Upstream
Released (8.44,2:8.39-13)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2:8.39-13)
Ubuntu 20.04 LTS (Focal Fossa) Needed

Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://vcs.pcre.org/pcre?view=revision&revision=1761