Your submission was sent successfully! Close

CVE-2020-10756

Published: 9 July 2020

An out-of-bounds read vulnerability was found in the SLiRP networking implementation of the QEMU emulator. This flaw occurs in the icmp6_send_echoreply() routine while replying to an ICMP echo request, also known as ping. This flaw allows a malicious guest to leak the contents of the host memory, resulting in possible information disclosure. This flaw affects versions of libslirp before 4.3.1.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
libslirp
Launchpad, Ubuntu, Debian
bionic Does not exist

eoan Does not exist

focal
Released (4.1.0-2ubuntu2.1)
groovy Not vulnerable
(4.3.1-1)
hirsute Not vulnerable
(4.3.1-1)
impish Not vulnerable
(4.3.1-1)
jammy Not vulnerable
(4.3.1-1)
precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

qemu
Launchpad, Ubuntu, Debian
bionic
Released (1:2.11+dfsg-1ubuntu7.31)
eoan Ignored
(reached end-of-life)
focal Not vulnerable
(uses system libslirp)
groovy Not vulnerable
(uses system libslirp)
hirsute Not vulnerable
(uses system libslirp)
impish Not vulnerable
(uses system libslirp)
jammy Not vulnerable
(uses system libslirp)
precise Does not exist

trusty Not vulnerable
(code not present)
upstream Needs triage

xenial Not vulnerable
(code not present)
qemu-kvm
Launchpad, Ubuntu, Debian
bionic Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Not vulnerable
(code not present)
trusty Does not exist

upstream Needs triage

xenial Does not exist

slirp4netns
Launchpad, Ubuntu, Debian
bionic Does not exist

eoan Ignored
(reached end-of-life)
focal Needed

groovy Not vulnerable
(1.0.1-1)
hirsute Not vulnerable
(1.0.1-1)
impish Not vulnerable
(1.0.1-1)
jammy Not vulnerable
(1.0.1-1)
precise Does not exist

trusty Does not exist

upstream
Released (1.0.1-1)
xenial Does not exist