Your submission was sent successfully! Close

CVE-2019-3871

Published: 21 March 2019

A vulnerability was found in PowerDNS Authoritative Server before 4.0.7 and before 4.1.7. An insufficient validation of data coming from the user when building a HTTP request from a DNS query in the HTTP Connector of the Remote backend, allowing a remote user to cause a denial of service by making the server connect to an invalid endpoint, or possibly information disclosure by making the server connect to an internal endpoint and somehow extracting meaningful information about the response

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
pdns
Launchpad, Ubuntu, Debian
Upstream
Released (4.1.6-2)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(4.1.6-3build1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.1.6-3build1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.1.6-3build1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)