CVE-2019-20807

Published: 28 May 2020

In Vim before 8.1.0881, users can circumvent the rvim restricted mode and execute arbitrary OS commands via scripting interfaces (e.g., Python, Ruby, or Lua).

Priority

Low

CVSS 3 base score: 5.3

Status

Package Release Status
vim
Launchpad, Ubuntu, Debian
Upstream
Released (2:8.1.2136-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2:8.1.2269-1ubuntu5)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2:8.1.2269-1ubuntu5)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2:8.0.1453-1ubuntu1.4)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2:7.4.1689-3ubuntu1.5)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Ubuntu 12.04 ESM (Precise Pangolin) Needed

Patches:
Upstream: https://github.com/vim/vim/commit/8c62a08faf89663e5633dc5036cd8695c80f1075
Upstream: https://github.com/vim/vim/commit/54d6fe5e60c0c488a424c078963ead40ae7dc397