CVE-2019-20477

Published: 19 February 2020

PyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load_all functions because of a class deserialization issue, e.g., Popen is a class in the subprocess module. NOTE: this issue exists because of an incomplete fix for CVE-2017-18342.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
pyyaml
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(5.3-1ubuntu2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)

Notes

AuthorNote
mdeslaur
CVE-2017-18342 resulted in the load() function being
deprecated in 5.1+ in eoan and later. It did not get fixed in
previous release because of compatibility issues. This CVE
therefore only really applies to eoan and later.

References