CVE-2019-17571

Published: 20 December 2019

Included in Log4j 1.2 is a SocketServer class that is vulnerable to deserialization of untrusted data which can be exploited to remotely execute arbitrary code when combined with a deserialization gadget when listening to untrusted network traffic for log data. This affects Log4j versions up to 1.2 up to 1.2.17.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
apache-log4j1.2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.2.17-9)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.2.17-9)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.2.17-9)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.2.17-8+deb10u1build0.18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Ignored
(not in esm-main list)