CVE-2019-17543

Published: 14 October 2019

LZ4 before 1.9.2 has a heap-based buffer overflow in LZ4_write32 (related to LZ4_compress_destSize), affecting applications that call LZ4_compress_fast with a large input. (This issue can also lead to data corruption.) NOTE: the vendor states "only a few specific / uncommon usages of the API are at risk."

Priority

Low

CVSS 3 base score: 8.1

Status

Package Release Status
lz4
Launchpad, Ubuntu, Debian
Upstream
Released (1.9.2-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.9.2-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.9.2-2)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Needs triage