Your submission was sent successfully! Close

CVE-2019-13616

Published: 15 October 2019

SDL (Simple DirectMedia Layer) through 1.2.15 and 2.x through 2.0.9 has a heap-based buffer over-read in BlitNtoN in video/SDL_blit_N.c when called from SDL_SoftBlit in video/SDL_blit.c.

From the Ubuntu security team

USN-4238-1 addressed serveral vulnerabilities in SDL_image. This update provides the corresponding fixes for Ubuntu 14.04 ESM.

Priority

Low

CVSS 3 base score: 8.1

Status

Package Release Status
libsdl1.2
Launchpad, Ubuntu, Debian
Upstream
Released (1.2.15+dfsg2-5)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.2.15+dfsg2-5)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.2.15+dfsg2-5)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.2.15+dfsg2-5)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.2.15+dfsg2-0.1ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.2.15+dfsg1-3ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.2.15-8ubuntu1.1+esm1)
Patches:
Upstream: https://hg.libsdl.org/SDL/rev/ad1bbfbca760
libsdl2
Launchpad, Ubuntu, Debian
Upstream
Released (2.0.10+dfsg1-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.0.10+dfsg1-1ubuntu1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.0.10+dfsg1-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.0.10+dfsg1-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://hg.libsdl.org/SDL/rev/e7ba650a643a
libsdl2-image
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.0.5+dfsg1-2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.0.5+dfsg1-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.0.5+dfsg1-2)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://hg.libsdl.org/SDL_image/rev/ba45f00879ba
sdl-image1.2
Launchpad, Ubuntu, Debian
Upstream
Released (1.2.12-12)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.2.12-12)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.2.12-12)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.2.12-12)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.2.12-8ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.2.12-5+deb9u1ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://hg.libsdl.org/SDL_image/rev/a59bfe382008