Your submission was sent successfully! Close

CVE-2019-11291

Published: 22 November 2019

Pivotal RabbitMQ, 3.7 versions prior to v3.7.20 and 3.8 version prior to v3.8.1, and RabbitMQ for PCF, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain two endpoints, federation and shovel, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack via the vhost or node name fields that could grant access to virtual hosts and policy management information.

Priority

Low

CVSS 3 base score: 3.5

Status

Package Release Status
rabbitmq-server
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.8.2-0ubuntu1.1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.6.10-1ubuntu0.4)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(3.5.7-1ubuntu0.16.04.4)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist