Your submission was sent successfully! Close

CVE-2019-11027

Published: 10 June 2019

Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
ruby-openid
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(2.9.2debian-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.9.2debian-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.9.2debian-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist