CVE-2018-19198

Published: 12 November 2018

An issue was discovered in uriparser before 0.9.0. UriQuery.c allows an out-of-bounds write via a uriComposeQuery* or uriComposeQueryEx* function because the '&' character is mishandled in certain contexts.

From the Ubuntu security team

It was discovered that uriparser mishandled certain input. An attacker could use this vulnerability to cause uriparser to crash or possibly execute arbitrary code.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
uriparser
Launchpad, Ubuntu, Debian
Upstream
Released (0.9.0-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(0.9.3-2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(0.9.3-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.9.3-2)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed