Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2018-18505

Published: 30 January 2019

An earlier fix for an Inter-process Communication (IPC) vulnerability, CVE-2011-3079, added authentication to communication between IPC endpoints and server parents during IPC process creation. This authentication is insufficient for channels created after the IPC process is started, leading to the authentication not being correctly applied to later channels. This could allow for a sandbox escape through IPC channels due to lack of message validation in the listener process. This vulnerability affects Thunderbird < 60.5, Firefox ESR < 60.5, and Firefox < 65.

Notes

AuthorNote
tyhicks
mozjs contains a copy of the SpiderMonkey JavaScript engine

Priority

Medium

Cvss 3 Severity Score

10.0

Score breakdown

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
bionic
Released (65.0+build2-0ubuntu0.18.04.1)
cosmic
Released (65.0+build2-0ubuntu0.18.10.1)
disco
Released (65.0+build2-0ubuntu1)
eoan
Released (65.0+build2-0ubuntu1)
focal
Released (65.0+build2-0ubuntu1)
groovy
Released (65.0+build2-0ubuntu1)
hirsute
Released (65.0+build2-0ubuntu1)
impish
Released (65.0+build2-0ubuntu1)
jammy
Released (65.0+build2-0ubuntu1)
kinetic
Released (65.0+build2-0ubuntu1)
lunar
Released (65.0+build2-0ubuntu1)
mantic
Released (65.0+build2-0ubuntu1)
noble
Released (65.0+build2-0ubuntu1)
trusty
Released (65.0+build2-0ubuntu0.14.04.1)
upstream
Released (65.0)
xenial
Released (65.0+build2-0ubuntu0.16.04.1)
mozjs38
Launchpad, Ubuntu, Debian
bionic Needs triage

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

noble Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs52
Launchpad, Ubuntu, Debian
bionic Needs triage

cosmic Ignored
(end of life)
disco Ignored
(end of life)
eoan Ignored
(end of life)
focal Needs triage

groovy Ignored
(end of life)
hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

noble Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

mozjs60
Launchpad, Ubuntu, Debian
bionic Does not exist

cosmic Ignored
(end of life)
disco Ignored
(end of life)
eoan Ignored
(end of life)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

noble Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

thunderbird
Launchpad, Ubuntu, Debian
bionic
Released (1:60.5.1+build2-0ubuntu0.18.04.1)
cosmic
Released (1:60.5.1+build2-0ubuntu0.18.10.1)
disco
Released (1:60.5.1+build2-0ubuntu1)
eoan
Released (1:60.5.1+build2-0ubuntu1)
focal
Released (1:60.5.1+build2-0ubuntu1)
groovy
Released (1:60.5.1+build2-0ubuntu1)
hirsute
Released (1:60.5.1+build2-0ubuntu1)
impish
Released (1:60.5.1+build2-0ubuntu1)
jammy
Released (1:60.5.1+build2-0ubuntu1)
kinetic
Released (1:60.5.1+build2-0ubuntu1)
lunar
Released (1:60.5.1+build2-0ubuntu1)
mantic
Released (1:60.5.1+build2-0ubuntu1)
noble
Released (1:60.5.1+build2-0ubuntu1)
trusty
Released (1:60.5.1+build2-0ubuntu0.14.04.1)
upstream
Released (60.5)
xenial
Released (1:60.5.1+build2-0ubuntu0.16.04.1)

Severity score breakdown

Parameter Value
Base score 10.0
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Changed
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H