CVE-2018-14645

Published: 21 September 2018

A flaw was discovered in the HPACK decoder of HAProxy, before 1.8.14, that is used for HTTP/2. An out-of-bounds read access in hpack_valid_idx() resulted in a remote crash and denial of service.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
haproxy
Launchpad, Ubuntu, Debian
Upstream
Released (1.8.13-2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.8.8-1ubuntu0.2)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected)