CVE-2018-1123

Published: 17 May 2018

procps-ng before version 3.3.15 is vulnerable to a denial of service in ps via mmap buffer overflow. Inbuilt protection in ps maps a guard page at the end of the overflowed buffer, ensuring that the impact of this flaw is limited to a crash (temporary denial of service).

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
procps
Launchpad, Ubuntu, Debian
Upstream
Released (3.3.15)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2:3.3.12-3ubuntu1.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2:3.3.10-4ubuntu2.4)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:3.3.9-1ubuntu2.3)
Patches:
Upstream: https://gitlab.com/procps-ng/procps/commit/136e3724952827bbae8887a42d9d2b6f658a48ab